Why doesn't my Rental Listing display the correct info that I configured? Ex: Deposit & Fee is wrong

I've configured every available option for my rental on Zillow, but these items do not reflect how I've configured them, either showing up as blank, "--," or as "No" when I've selected "Yes." The erroneous options I'm trying to fix are:

Deposit & Fees:      --
High-speed internet ready:     No
Cable/satelite TV-ready:     No

The listing is here:
http://www.zillow.com/homedetails/290-Pleasant-St-APT-205-Watertown-MA-02472/80389945_zpid/
  • July 21 2010 - Watertown
  • 0
    0Yes

  • Report a Problem

    Please enter a valid email address.

    Content flagged

    We will review this content. Thanks for helping make the site more useful to everyone. To learn more, read Zillow's Good Neighbor Policy.

    We're sorry. This service is temporarily unavailable. Please come back later and try again.

Be a Good Neighbor. Be respectful and on-topic. No spam or self-promotion! See our Good Neighbor Policy.

Answers (2)

Profile picture for wetdawgs
I assuming you hit the "save" button?   Yeah, I know this is in the "when all else fails, check to see if it is plugged in" mode, but I've seen several people skip the save button.
  • July 21 2010
  • 0Yes

  • Report a Problem

    Please enter a valid email address.

    Content flagged

    We will review this content. Thanks for helping make the site more useful to everyone. To learn more, read Zillow's Good Neighbor Policy.

    We're sorry. This service is temporarily unavailable. Please come back later and try again.

Paul click the gray flag and it will notify Zillow of a problem
  • July 21 2010
  • 0Yes

  • Report a Problem

    Please enter a valid email address.

    Content flagged

    We will review this content. Thanks for helping make the site more useful to everyone. To learn more, read Zillow's Good Neighbor Policy.

    We're sorry. This service is temporarily unavailable. Please come back later and try again.